Description
Downlaod Brochures&Data Sheets
Product Features
- Die-cast aluminum alloy protects the system’s internal components, achieving an IP67 rating for explosion-proof, waterproof, moisture-proof, dust-proof, and freeze-proof protection.
- Supports SIP standard network protocols, 36-48V programmable switches, and direct fiber optic connections.
- Equipped with a 30W speaker and LED flashlight for incoming call alerts and message broadcasts.
- Multiple numbers can be pre-stored for one-touch dialing in emergencies.
- Ring count detection and automatic broadcasting after each ring.
- Supports one-touch group calls and broadcasts without server interaction.
- An alarm light flashes when a call is received to prevent missed calls.
- Equipped with an intercom button for intercom broadcasts.
- A stainless steel keypad and handle pull cord reduce maintenance requirements.
- A stainless steel door lock resists wind when installed outdoors.
Basic Parameters
| Size | 346*301*138MM |
| Weight | 8.5KG |
| Explosion-proof marking | Ex db ib IIC T6 Gb/Ex tbllIC T80℃ Db |
| Shell material | Aluminum alloy |
| Keyboard material | stainless steel |
| color | Red, yellow (optional) |
| Communication mode | SIP , analog, and direct fiber optic |
| Installation method | Wall-mounted |
| Power supply | 220V power supply (POE and DC are optional) |
| Protection level | IP66 |
| Operating temperature | -20℃ to +80℃ |
| Operating humidity | 10-95% |
Product Configuration
Network
- SIP V1 (RFC2543), V2 (RFC3261) protocol
- backup server
- proxy servers and peer-to-peer connection modes
- stationary IP / DHCP / PPPoE dialing
- TFTP / DHCP / PPPoE client side
- Telnet / HTTP / HTTPS services
- network time SNTP protocol
- DNS SRV (RFC3263)
- DNS client side, built-in NAT / DHCP service
Audio
- Supports broadband high definition coding: L16G and G.722;
- 711a / u, G.726, G.729a / b, G.723, iLBC and other compression coding;
- VAD (silent dete ction), CNG (comfortable noise);
Special Features
- One-touch IP address announcement: Press and hold the hands-free button for ten seconds to automatically announce the IP address. (Or, pick up the handset and enter *114*.)
- Three SIP accounts are provided. If the first account is offline, it automatically switches to the next account, ensuring smooth communication.
- Two emergency buttons allow you to call an alarm or a designated number with one click.
DIMENSIONS
Product Dimensions Diagram


Frequently Asked Questions
Q:Is this product certified for explosion protection?
A:Yes.the product has passed the IP67 explosion-proof test.
Q: Do you offer technical support?
A: Yes, we provide full technical support via email, phone, or live chat for both pre-sales consultation and after-sales service.





